sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
sk1 in Debian Squeeze
macaronij
#1 Print Post
Posted on 18-05-2010 14:04
Member

Posts: 4
Joined: 18.05.10

Hi all, i'm trying to install sk1 on my desktop
i found uniconvertor in synaptic but did not found sk1
when i try to install sk1libs

debian:/home/imprenta/sk1/sk1libs-0.9.1# python setup.py install
running install
running build
running build_py
running build_ext
building 'sk1libs.pycms._pycms' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DMAJOR_VERSION=1 -DMINOR_VERSION=0 -I/usr/include/python2.5 -c src/pycms/_pycms.c -o build/temp.linux-i686-2.5/src/pycms/_pycms.o -Wall
src/pycms/_pycms.c:20:20: error: Python.h: No existe el fichero o el directorio
src/pycms/_pycms.c:21:18: error: lcms.h: No existe el fichero o el directorio
In file included from src/pycms/Imaging.h:14,
from src/pycms/_pycms.c:22:
src/pycms/ImPlatform.h:14:2: error: #error Sorry, this library requires support for ANSI prototypes.
src/pycms/ImPlatform.h:17:2: error: #error Sorry, this library requires ANSI header files.
src/pycms/ImPlatform.h:55:2: error: #error Cannot find required 32-bit integer type
In file included from src/pycms/_pycms.c:22:
src/pycms/Imaging.h:90: error: expected specifier-qualifier-list before ‘INT32’
src/pycms/Imaging.h:263: error: expected specifier-qualifier-list before ‘INT32’
src/pycms/Imaging.h:391: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ImagingCRC32’
src/pycms/_pycms.c:26: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
src/pycms/_pycms.c:31: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘getLCMStype’
src/pycms/_pycms.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:125: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:164: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:179: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:210: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:242: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:271: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:288: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:305: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:327: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:351: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:377: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘pycms_methods’
src/pycms/_pycms.c: In function ‘init_pycms’:
src/pycms/_pycms.c:396: warning: implicit declaration of function ‘Py_InitModule’
src/pycms/_pycms.c:396: error: ‘pycms_methods’ undeclared (first use in this function)
src/pycms/_pycms.c:396: error: (Each undeclared identifier is reported only once
src/pycms/_pycms.c:396: error: for each function it appears in.)
error: command 'gcc' failed with exit status 1
 
igor
#2 Print Post
Posted on 18-05-2010 20:15
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi!

There are two problem causes in your stack trace:

src/pycms/_pycms.c:20:20: error: Python.h: No existe el fichero o el directorio
src/pycms/_pycms.c:21:18: error: lcms.h: No existe el fichero o el directorio


It seems you need installing libpython-dev and liblcms-dev packages to resolve the issue.
Regards,

Igor Novikov
sK1 Project
 
macaronij
#3 Print Post
Posted on 19-05-2010 13:24
Member

Posts: 4
Joined: 18.05.10

installed liblcms-dev but couldn t find libpython-dev
now i got

debian:/home/imprenta/sk1/sk1libs-0.9.1# python setup.py install
running install
running build
running build_py
running build_ext
building 'sk1libs.pycms._pycms' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DMAJOR_VERSION=1 -DMINOR_VERSION=0 -I/usr/include/python2.5 -c src/pycms/_pycms.c -o build/temp.linux-i686-2.5/src/pycms/_pycms.o -Wall
src/pycms/_pycms.c:20:20: error: Python.h: No existe el fichero o el directorio
In file included from src/pycms/Imaging.h:14,
from src/pycms/_pycms.c:22:
src/pycms/ImPlatform.h:14:2: error: #error Sorry, this library requires support for ANSI prototypes.
src/pycms/ImPlatform.h:17:2: error: #error Sorry, this library requires ANSI header files.
src/pycms/ImPlatform.h:55:2: error: #error Cannot find required 32-bit integer type
In file included from src/pycms/_pycms.c:22:
src/pycms/Imaging.h:90: error: expected specifier-qualifier-list before ‘INT32’
src/pycms/Imaging.h:263: error: expected specifier-qualifier-list before ‘INT32’
src/pycms/Imaging.h:391: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ImagingCRC32’
src/pycms/_pycms.c:26: error: expected specifier-qualifier-list before ‘PyObject_HEAD’
src/pycms/_pycms.c:70: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:91: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:125: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:164: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:179: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:210: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:242: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:271: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:288: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:305: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:327: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:351: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘*’ token
src/pycms/_pycms.c:377: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘pycms_methods’
src/pycms/_pycms.c: In function ‘init_pycms’:
src/pycms/_pycms.c:396: warning: implicit declaration of function ‘Py_InitModule’
src/pycms/_pycms.c:396: error: ‘pycms_methods’ undeclared (first use in this function)
src/pycms/_pycms.c:396: error: (Each undeclared identifier is reported only once
src/pycms/_pycms.c:396: error: for each function it appears in.)
error: command 'gcc' failed with exit status 1
 
max
#4 Print Post
Posted on 19-05-2010 20:25
Administrator

Posts: 63
Joined: 09.05.09

python2.5-dev or python2.6-dev


Regards,

Maxim Barabash
sK1 Project
 
macaronij
#5 Print Post
Posted on 26-05-2010 22:02
Member

Posts: 4
Joined: 18.05.10

instaled 2.6 dev same problem, instaled python3.1 and 3-dev and same problem....
¿any ideas?
 
macaronij
#6 Print Post
Posted on 28-05-2010 21:52
Member

Posts: 4
Joined: 18.05.10

somene could pehaps create a deb for debian squeezy?
ubuntu changes evry 6 months, but a deb for debian will last (at least) for 2 years...
 
Jump to Forum: