sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
building uniconverter fails on OSX
jhilden
#1 Print Post
Posted on 23-05-2010 11:48
Member

Posts: 1
Joined: 23.05.10

Hi, when trying to build uniconvertor I keep getting the following error message, after which follows a string of errors:

src/modules/filter/streamfilter.c:24:20: error: Python.h: No such file or directory
In file included from src/modules/filter/streamfilter.c:26:
src/modules/filter/filterobj.h:31: error: expected declaration specifiers or ‘...’ before ‘*’ token
src/modules/filter/filterobj.h:31: error: expected declaration specifiers or ‘...’ before ‘PyObject’
src/modules/filter/filterobj.h:32: error: expected declaration specifiers or ‘...’ before ‘size_t’


... etc.
Then it exits with:
lipo: can't open input file: /var/folders/b2/b2ibDIFuFo4YUcoceP5KB++++TI/-Tmp-//ccN5kLtn.out (No such file or directory)
error: command 'gcc-4.2' failed with exit status 1


I run OS X 10.6.3 and Python 2.6.5
Is it an issue with C libraries? I would very much appreciate help, since I am not very proficient in these things.
Best, Jonatan
 
igor
#2 Print Post
Posted on 23-05-2010 16:05
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi,

Here is an error cause:

error: Python.h: No such file or directory


You need installing Python headers to compile UniConvertor.

I would recommend you waiting for UniConvertor 1.1.5 We are going to provide .pkg for Leopard and Snow Leopard because we have gotten recently Apple hardware. Binaries are expected on first week of June.
Regards,

Igor Novikov
sK1 Project
Edited by igor on 23-05-2010 16:06
 
philippp
#3 Print Post
Posted on 29-07-2010 12:17
Member

Posts: 2
Joined: 29.07.10

igor wrote:
I would recommend you waiting for UniConvertor 1.1.5 We are going to provide .pkg for Leopard and Snow Leopard because we have gotten recently Apple hardware. Binaries are expected on first week of June.


Hi,
looks like 1.1.5 is there, but I could not find the download for OSX!?

I wanted to install uniconvertor for use with Inkscape on OS X.
(I tried to do it via MacPort, but finally there is some compile error at the sklibs, and I do not have time to troubleshoot this.) Frown
(I am even more curious about sK1 being released for OSX! :-)

Thanks, and greetings from Vienna,
Philipp
 
kfsix
#4 Print Post
Posted on 02-08-2010 23:21
Member

Posts: 1
Joined: 02.08.10

Hi there! One more hoping for the osx .pkg! Thanks a lot for your great work. Uniconv has been very useful, even thought I always struggle to compile it and its dependencies, so the pkg would be great!!!

K.
 
Jump to Forum: