sK1 Project :: OpenSource Solutions for Prepress
View Thread
sK1 Project :: Other subprojects :: Any other issues
 Print Thread
Problem on Ubuntu Natty with python-skencil-1.0alpha-rev784_0ubuntu1_10.10_i386.deb
sdaau
#1 Print Post
Posted on 27-03-2011 15:52
Member

Posts: 2
Joined: 26.12.10

Hi all,

I just tried downloading and installing
python-skencil-1.0alpha-rev784_0ubuntu1_10.10_i386.deb on Ubuntu Natty, and get the following problem:
Download source  Code

$ skencil
Traceback (most recent call last):
  File "/usr/bin/skencil", line 4, in <module>
    from skencil import skencil_run
ImportError: No module named skencil





The problem is that in Natty, python 2.7 is default - yet skencil gets installed in dist-packages of python 2.6; easiest for me was to put a symlink in 2.7 packages:
Download source  Code

sudo ln -s /usr/lib/python2.6/dist-packages/skencil /usr/lib/python2.7/dist-packages/




... and program could then run again :)

Hope this helps someone,

Cheers!
 
bullgr
#2 Print Post
Posted on 21-07-2011 09:42
Member

Posts: 2
Joined: 21.07.11

This don't work for me in ubuntu 11.04... I haven't even a skencil folder...

After a little strugling i found the solution...
*First of all, install from your package manager python v. 2.6 & libpython2.6
*symlink the three sk1 folders to the python 2.7 folder:
Download source  Code
sudo ln -s /usr/lib/python2.6/dist-packages/sk1 /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1libs /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1 /usr/lib/python2.7/dist-packages/



...and you are done...:D
Edited by bullgr on 21-07-2011 09:43
 
john0
#3 Print Post
Posted on 03-08-2011 01:52
Member

Posts: 2
Joined: 03.08.11

#1 above works for me for the skencil update.

To get sk1 running, post #2 almost works, but I think there's an error on the last line, where it should link sk1sdk, rather than try to link sk1 again. So for me, following works:

Download source  Code
sudo ln -s /usr/lib/python2.6/dist-packages/sk1 /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1libs /usr/lib/python2.7/dist-packages/
sudo ln -s /usr/lib/python2.6/dist-packages/sk1sdk /usr/lib/python2.7/dist-packages/



 
Jump to Forum: