sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
problems with sk1 on debian installed from source
ferpof
#1 Print Post
Posted on 20-05-2011 09:00
Member

Posts: 8
Joined: 20.05.11

Hello,
I installed the sK1 tarball from source as root following the steps indicated:
1.- python setup.py install for sk1libs
2.- python setup.py install for sk1sdk
3.- python setup.py install for sk1

I also installed the packages required and mentioned in several forums & FAQ I checked previous to this post:

libcairo2-dev
libfreetype6-dev
liblcms1-dev
libc6-dev
libxext-dev
python2.5-dev
python-cairo-dev
python-imaging
python-imaging-tk
python-reportlab
tcl8.5
tcl8.5-dev
tk8.5
tk8.5-dev
x11proto-xext-dev
zlib1g
zlib1g-dev

When I run sk1 I obtain the following result in console:
--------------------
[email protected]:~$ /usr/bin/sk1
Traceback (most recent call last):
File "/usr/bin/sk1", line 23, in <module>
sk1_run()
File "/usr/lib/python2.5/site-packages/sk1/__init__.py", line 28, in sk1_run
app.main.main()
File "/usr/lib/python2.5/site-packages/sk1/app/main.py", line 150, in main
application = SketchApplication(filename, options.display, options.geometry, run_script = options.run_script)
File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 155, in __init__
TkApplication.__init__(self, screen_name = screen_name, geometry = geometry)
File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 60, in __init__
self.init_tk(screen_name, geometry)
File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 190, in init_tk
TkApplication.init_tk(self, screen_name = screen_name, geometry = geometry)
File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 68, in init_tk
app.uimanager=UIManager(self.root)
File "/usr/lib/python2.5/site-packages/sk1/app/managers/uimanager.py", line 27, in __init__
self.style=tkstyle.get_system_style(root)
File "/usr/lib/python2.5/site-packages/sk1sdk/tkstyle/__init__.py", line 65, in get_system_style
style.colors=ColorScheme(colors.SYSTEM_SCHEME)
File "/usr/lib/python2.5/site-packages/sk1sdk/tkstyle/colors.py", line 113, in __init__
self.import_gtk_colors()
File "/usr/lib/python2.5/site-packages/sk1sdk/tkstyle/colors.py", line 153, in import_gtk_colors
colors[type+' normal']=gtk_to_tk_color(line[0])
IndexError: list index out of range
--------------------
I also installed from the ubuntu packages and I got other errors.

Any idea about this problem?

Suggestions will be acknowledged, since I have read that this package is great !
 
igor
#2 Print Post
Posted on 21-05-2011 04:16
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

sk1 depends on python-gtk. Did you install the package?
Regards,

Igor Novikov
sK1 Project
Edited by igor on 21-05-2011 04:17
 
ferpof
#3 Print Post
Posted on 21-05-2011 08:27
Member

Posts: 8
Joined: 20.05.11

Ok, that was the problem. I installed the package mentioned and now sK1 starts without problems. I will try it.

Many thanks
 
igor
#4 Print Post
Posted on 21-05-2011 10:18
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

BTW you can find all dependencies in setup.cfg files.
Regards,

Igor Novikov
sK1 Project
 
Jump to Forum: