sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
Problem about unrecognized file type on Mac
zhaoxitao
#1 Print Post
Posted on 03-10-2011 10:21
Member

Posts: 5
Joined: 02.06.11

Hi, i come form china,so my english is not good,sorry
i was install UniCovertor wiht no error
but i used unicovertor have this problem
Download source  Code

$ uniconvertor 2.cdr 2.ai
Traceback (most recent call last):
  File "/usr/local/bin/uniconvertor", line 13, in <module>
    uniconv_run()
  File "/Library/Python/2.6/site-packages/uniconvertor/__init__.py", line 95, in uniconv_run
    doc = load.load_drawing(input_file)
  File "/Library/Python/2.6/site-packages/uniconvertor/app/io/load.py", line 377, in load_drawing
    return load_drawing_from_file(file, filename)
  File "/Library/Python/2.6/site-packages/uniconvertor/app/io/load.py", line 359, in load_drawing_from_file
    raise SketchLoadError(_("unrecognised file type"))
app.events.skexceptions.SketchLoadError: unrecognised file type




My OS ver is Mac OS X 16.0.8

but when i used CDR explorer i can preview this files
Edited by zhaoxitao on 03-10-2011 10:27
 
igor
#2 Print Post
Posted on 04-10-2011 11:16
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi,

Could you please providing us this file? It would be great to investigate this issue.
Regards,

Igor Novikov
sK1 Project
 
vdalakas
#3 Print Post
Posted on 08-10-2011 19:33
Member

Posts: 2
Joined: 08.10.11

Hi,

I have a similar problem with the installation on MAC OS X 10.6.8.
I have downloaded the files and I have used the commands proposed here http://sk1project.org/forum/viewthread.php?thread_id=44 in order to build and install.
After that I have copied file uniconvertor from scripts-2.7 to /opt/local/bin and I tried to open a .cdr file. The error is

UniConvertor failed:

Traceback (most recent call last):
File "/opt/local/bin/uniconvertor", line 13, in <module>
uniconv_run()
File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/uniconvertor/__init__.py", line 95, in uniconv_run
doc = load.load_drawing(input_file)
File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/uniconvertor/app/io/load.py", line 377, in load_drawing
return load_drawing_from_file(file, filename)
File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/uniconvertor/app/io/load.py", line 354, in load_drawing_from_file
raise SketchLoadError(_("Parsing error: "Wink+ str(value))
app.events.skexceptions.SketchLoadError: Parsing error: unrecognised file type

I get the same error with python26 also.

Do you have any suggestions? Do I have to copy something inside /Applications/Inkscape.app/Contents ?

Thank you

Vassilis

___________________

Please ignore it. The error was a result of X5 version of the cdr file. When the cdr file was exported as X4 version no error occurred during import.
Edited by vdalakas on 09-10-2011 08:30
 
igor
#4 Print Post
Posted on 09-10-2011 10:42
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi,

Could you test your CDR file using Windows or Linux version of UniConvertor?
Regards,

Igor Novikov
sK1 Project
 
vdalakas
#5 Print Post
Posted on 11-10-2011 03:03
Member

Posts: 2
Joined: 08.10.11

Ubuntu 11 installation returns this after trying

uniconvertor subcarriers.cdr subcarriers.svg

Traceback (most recent call last):
File "/usr/bin/uniconvertor", line 12, in <module>
from uniconvertor import uniconv_run
ImportError: No module named uniconvertor
 
igor
#6 Print Post
Posted on 11-10-2011 16:57
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

vdalakas wrote:
Ubuntu 11 installation returns this after trying

uniconvertor subcarriers.cdr subcarriers.svg

Traceback (most recent call last):
File "/usr/bin/uniconvertor", line 12, in <module>
from uniconvertor import uniconv_run
ImportError: No module named uniconvertor


It's just because you are using packages created for previous Ubuntu version.
Regards,

Igor Novikov
sK1 Project
 
Jump to Forum: