sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
Problems with pycms on mac
iVanSh
#1 Print Post
Posted on 01-11-2011 19:44
Member

Posts: 2
Joined: 01.11.11

Hello! After a long-long dancing and googling I'v got sk1libs installed on my Mac (10.6.5 Snow Leo), then it was easy to install uniconvertor. But it doesnt work! The error is:
Download source  Code
uniconvertor file.cdr file.svg
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/Current/bin/uniconvertor", line 13, in <module>
    uniconv_run()
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/uniconvertor/__init__.py", line 83, in uniconv_run
    from app.io import load
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/uniconvertor/app/__init__.py", line 69, in <module>
    from conf.configurator import Configurator
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/uniconvertor/app/conf/configurator.py", line 11, in <module>
    from app.events import connector
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/uniconvertor/app/__init__.py", line 72, in <module>
    from managers.colormanager import ColorManager
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/uniconvertor/app/managers/colormanager.py", line 9, in <module>
    from sk1libs.pycms import cmsOpenProfileFromFile,cmsCreateTransform,cmsDoTransform, \
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/sk1libs/pycms/__init__.py", line 22, in <module>
    import _pycms, os, types
ImportError: dynamic module does not define init function (init_pycms)



 
igor
#2 Print Post
Posted on 01-11-2011 23:08
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi,

It's a really strange message because init function is defined in _pycms.c :

Download source  Code

void
init_pycms(void)
{
    Py_InitModule("_pycms", pycms_methods);
}





I think the problem cause is rather incomplete/incorrect build.
Regards,

Igor Novikov
sK1 Project
 
iVanSh
#3 Print Post
Posted on 02-11-2011 03:36
Member

Posts: 2
Joined: 01.11.11

Thanks for quick answer, Igor.
I recompiled sk1libs with these options:
Download source  Code
CFLAGS="-I/opt/local/include -I/opt/local/include/freetype2" LDFLAGS="-L/opt/local/lib" python setup.py build




And used Python 2.6 instead of 2.5 - now it works!
Thanks for your app!
Edited by iVanSh on 02-11-2011 04:12
 
Jump to Forum: