sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
SK1 won't start in Ubuntu 11.04 64bit, nor in 10.04 64bit
Xikander
#1 Print Post
Posted on 15-12-2011 16:53
Member

Posts: 3
Joined: 15.12.11

Hello,

I have just downloaded sk1-rev1383_packages_for_ubuntu_11.04_amd64.zip to run on my Ubuntu 11.04 /64bit PC. After unzipping and install according to the instructions, I started sk1, just to get a "Segmentation fault", nothing else.

I then downloaded sk1-rev1383_packages_for_ubuntu_10.04_amd64.zip to install it on another machine running Ubuntu 10.04 / 64bit with the same result: "Segmentation fault". No more explanation.

What am I doing wrong? Has anybody succeeded to run SK1 on a 64bit Ubuntu 11.04 or 10.04?

Note if this is of any relevance: I also have Inkscape 0.48 installed which, I think, uses Uniconvertor as import filter (pretty poorly as CDR files don't import any text, just a couples of lines and simple forms). Could this interfere with SK1?

Thanks in advance
 
dcbevins
#2 Print Post
Posted on 07-01-2012 05:29
Member

Posts: 3
Joined: 07.11.11

Did you install all three packages?

As per: http://sk1project.org/modules.php?name=Products&product=sk1&op=download

"sK1 application is splitted on 3 packages: sk1, sk1sdk and sk1libs"

You may also need these packages: tcl8.5 tk8.5 python-imaging python-imaging-tk python-liblcms python-reportlab

UniConvertor may also be required.

I've yet to get the tkXcursor to go.
Edited by dcbevins on 07-01-2012 05:29
 
Xikander
#3 Print Post
Posted on 08-01-2012 14:58
Member

Posts: 3
Joined: 15.12.11

dcbevins wrote:
Did you install all three packages?

As per: http://sk1project.org/modules.php?name=Products&product=sk1&op=download

"sK1 application is splitted on 3 packages: sk1, sk1sdk and sk1libs"

You may also need these packages: tcl8.5 tk8.5 python-imaging python-imaging-tk python-liblcms python-reportlab

UniConvertor may also be required.

I've yet to get the tkXcursor to go.


Hello, thank you for answering. Yes I installed everything according to the instructions. I have Uniconvertor as well. I tried the same installation on a 32 bit 11.04 Ubuntu and it worked OK. It looks as this only happens on 64bit systems. Any clue?
Regards.
 
Victor
#4 Print Post
Posted on 06-02-2012 15:48
User Avatar

Member

Posts: 24
Joined: 13.05.09

Hm looks like it is some bug.
Could you please attache full error log from the console ?
E.g. try to run Sk1 from the terminal and then copy all trace from CMD.
 
Xikander
#5 Print Post
Posted on 09-02-2012 15:19
Member

Posts: 3
Joined: 15.12.11

Victor wrote:
Hm looks like it is some bug.
Could you please attache full error log from the console ?
E.g. try to run Sk1 from the terminal and then copy all trace from CMD.


Well, starting Sk1 from the terminal just gives:

~$ Segmentation fault

and nothing more happens!
 
Jump to Forum: