sK1 Project :: OpenSource Solutions for Prepress
View Thread
 Print Thread
Can't import the Python Imaging Library on Mac OS X Leopard
vizkr
#1 Print Post
Posted on 10-01-2010 19:34
Member

Posts: 1
Joined: 10.01.10

Just built unconv under Mac OS X 10.5.8 that is running python 2.5.1 and all seemed well but I got this error when I gave the app a test drive. Unfortunately my python is rather weak.

Anyone able to point me in the right direction?


Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/Library/Python/2.5/site-packages/uniconvertor/__init__.py", line 64, in <module>
from app.io import load
File "/Library/Python/2.5/site-packages/uniconvertor/app/__init__.py", line 62, in <module>
from conf.configurator import Configurator
File "/Library/Python/2.5/site-packages/uniconvertor/app/conf/configurator.py", line 11, in <module>
from app.events import connector
File "/Library/Python/2.5/site-packages/uniconvertor/app/__init__.py", line 114, in <module>
_import_PIL()
File "/Library/Python/2.5/site-packages/uniconvertor/app/__init__.py", line 103, in _import_PIL
warn.warn(warn.USER, "Can't import the Python Imaging Library"Wink
NameError: global name 'warn' is not defined
 
igor
#2 Print Post
Posted on 10-01-2010 20:29
User Avatar

Super Administrator

Posts: 220
Joined: 09.02.09

Hi!

I think you can try using PIL package on following resource:
http://pythonmac....index.html
Regards,

Igor Novikov
sK1 Project
 
Jump to Forum: