Thread subject: sK1 Project :: Does sK1 require compiz?

Posted by StevenD57 on 16-05-2009 19:07
#1

I have built and installed an rpm of the latest 0.9.0 sK1 bits on my Fedora9 system.
However when I try to run the resulting binary I get the following:

$ sk1 Documents/old_linux_logog_platypus1.svg
shared memory images supported
Cairo initialized!
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 73 (X_GetImage)
Serial number of failed request: 12553
Current serial number in output stream: 12553

I seem to have satisfied the various rpm build & install requirements but I cannot seem to find any information regarding this error.

Does running sK1 require compiz or something else I am not aware of?

My display is running the following:

default visual id: 0x21
visual:
visual id: 0x21
class: TrueColor
depth: 24 planes
available colormap entries: 256 per subfield
red, green, blue masks: 0xff0000, 0xff00, 0xff
significant bits in color specification: 8 bits

root window id: 0x75
depth of root window: 24 planes
number of colormaps: minimum 1, maximum 1
default colormap: 0x20
default number of colormap cells: 256
preallocated pixels: black 0, white 16777215
options: backing-store YES, save-unders YES