Thread subject: sK1 Project :: SK1 not running on Ubuntu 10.10

Posted by probharat on 02-02-2011 05:57
#1

Hi,
I am a new user to SK1 and using Ubuntu 10.10. Whenever I try to run the program through terminal, it gets terminated by giving the below error. Please advise the remedy for the same.

$ sk1
Traceback (most recent call last):
File "/usr/bin/sk1", line 23, in <module>
sk1_run()
File "/usr/lib/python2.6/dist-packages/sk1/__init__.py", line 19, in sk1_run
os.environ['LANG'] = lang[0] + lang[1].upper()
IndexError: list index out of range

Posted by ajitarsh on 06-08-2011 08:34
#2

I am also facing the same problem in Ubuntu 10.04.

I've just installed SK1 illustration Program and UniConvertor in Ubuntu 10.04. SK1 illustration program is not launching. And UniConvertor gives me a Error when I tried to convert a cdr file to svg.

[email protected]:~$ cd Downloads/
[email protected]:~/Downloads$ ls *.cdr
Hexapod.cdr
[email protected]:~/Downloads$ for i in `find . -print | grep -i '.cdr'`; do uniconvertor $i $i.svg; echo "converted" $i; done
Traceback (most recent call last):
File "/usr/lib/python2.6/dist-packages/sk1libs/filters/import/cdrloader.py", line 837, in Load
self.import_curves()
File "/usr/lib/python2.6/dist-packages/sk1libs/filters/import/cdrloader.py", line 880, in import_curves
self.begin_page("",layout)
AttributeError: CDRLoader instance has no attribute 'begin_page'
Traceback (most recent call last):
File "/usr/bin/uniconvertor", line 13, in <module>
uniconv_run()
File "/usr/lib/python2.6/dist-packages/uniconvertor/__init__.py", line 95, in uniconv_run
doc = load.load_drawing(input_file)
File "/usr/lib/python2.6/dist-packages/uniconvertor/app/io/load.py", line 377, in load_drawing
return load_drawing_from_file(file, filename)
File "/usr/lib/python2.6/dist-packages/uniconvertor/app/io/load.py", line 354, in load_drawing_from_file
raise SketchLoadError(_("Parsing error: ")+ str(value))
app.events.skexceptions.SketchLoadError: Parsing error: CDRLoader instance has no attribute 'begin_page'
converted ./Hexapod.cdr

gzip: stdout: Broken pipe
Traceback (most recent call last):
File "/usr/bin/uniconvertor", line 13, in <module>
uniconv_run()
File "/usr/lib/python2.6/dist-packages/uniconvertor/__init__.py", line 95, in uniconv_run
doc = load.load_drawing(input_file)
File "/usr/lib/python2.6/dist-packages/uniconvertor/app/io/load.py", line 377, in load_drawing
return load_drawing_from_file(file, filename)
File "/usr/lib/python2.6/dist-packages/uniconvertor/app/io/load.py", line 354, in load_drawing_from_file
raise SketchLoadError(_("Parsing error: ")+ str(value))
app.events.skexceptions.SketchLoadError: Parsing error: unrecognised file type
converted ./uniconvertor-cdr_explorer.tar.gz
[email protected]:~/Downloads$


I am a simple Ubuntu user, what should I do in this case. :|

Edited by ajitarsh on 06-08-2011 08:58

Posted by igor on 06-08-2011 13:48
#3

Hi,

it seems you tried converting CDR X5 file. This version is not supported yet. Anyway we would appreciate if you will provide us a file to reproduce the problem.

Concerning broken sK1 installation, please try latest sK1 packages and if you will find any problem, it would be great to post here an error stack trace.