Thread subject: sK1 Project :: Cannot find Python binding for LittleCMS! (again, sorry)

Posted by pbhj on 22-06-2009 13:37

Tried to post and lost my entry ... gah (my fault I think).

Anyway, tried using sk1_0.9.1pre_rev730-1_amd64.deb and following the installation guide on the download page but fails with "Cannot find Python binding for LittleCMS!".

Tried doing the suggested link "sudo ln -s /usr/share/python-support/python-liblcms/ /usr/lib/python2.5/site-packages/". Same error, also tried a link to "/usr/lib/python2.6".

Tried removing profile from ~/.sK1 (ie removed whole directory) but no help there.

Tried the SVN download as suggested by Ulysses, including the preinstallation of lots of possible deps, I got version 757 from trunk. But again, same error.

Have tried to start from command line, but python -i simply won't start, python -c "import sK1" gives the same error and nothing else. Now I have the SVN version I have to start from "sh ./src/sK1" in the sK1 checkout directory (ie python setup didn't had a link in my path for some reason).

gdb won't start as sK1 isn't a binary. strace gives me nothing useful.

My lcms / python-liblcms are version 1.18 from the jaunty repos.

Any help appreciated. Thanks.

Posted by igor on 26-06-2009 00:48

Unfortunately python-lcms package is a main problem source for sK1 installation. I would recommend you to wait for next preview tarball. Now we are fixing this issue replacing python-lcms dependency by own LittleCMS binding which will be compiled as sK1 module.

Posted by tuttul on 16-10-2009 10:25

Hi Igor,

In compiling sk1-0.9.1pre_rev730.tar.gz, there are no errors at all and also all installation process in succeded. This is the failure I have:

Cannot find Python binding for LittleCMS!

I give a try to another version that is 875 and I got problem compiling it in OpenSUSE64 11.1 in finding libtk: (I have complete development library of them)

python install
Source tree scan... is created
running install
running build
running build_py
package init file 'src/app/modules/' not found (or not a regular file)
package init file 'src/app/tcl/' not found (or not a regular file)
package init file 'src/app/modules/' not found (or not a regular file)
package init file 'src/app/tcl/' not found (or not a regular file)
running build_ext
building '' extension
gcc -pthread -shared build/temp.linux-x86_64-2.6/src/extentions/skmod/curvedraw.o build/temp.linux-x86_64-2.6/src/extentions/skmod/curvefunc.o build/temp.linux-x86_64-2.6/src/extentions/skmod/curvelow.o build/temp.linux-x86_64-2.6/src/extentions/skmod/curvemisc.o build/temp.linux-x86_64-2.6/src/extentions/skmod/curveobject.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skaux.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skcolor.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skdither.o build/temp.linux-x86_64-2.6/src/extentions/skmod/_sketchmodule.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skfm.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skimage.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skpoint.o build/temp.linux-x86_64-2.6/src/extentions/skmod/skrect.o build/temp.linux-x86_64-2.6/src/extentions/skmod/sktrafo.o -L/usr/lib64 -lm -lX11 -lXext -ltk -ltcl -lcairo -lpython2.6 -o build/lib.linux-x86_64-2.6/sk1/app/modules/
/usr/lib64/gcc/x86_64-suse-linux/4.3/../../../../x86_64-suse-linux/bin/ld: cannot find -ltk
collect2: ld returned 1 exit status
error: command 'gcc' failed with exit status 1



Posted by max on 16-10-2009 12:25

Hi tuttul,

You need to install dev packages for tcl and tk.
For example tk8.5-dev tcl8.5-dev or tk8.6-dev tcl8.6-dev.
The python-lcms package is removed from dependencies.
More is required to compile and install sk1libs package .
svn co sk1libs