Thread subject: sK1 Project :: UniConvertor error at Mac OS X Sonw Leopard,Help!!!

Posted by zhaoxitao on 03-06-2011 08:16
#1

Hi,
i come for China,so my english is not good~~ Sorry

i was installed UniConvertor and sk1libs with no error,but when i run this program,had this error
Code

zhaoxitao$ uniconvertor 1.cdr 1.ai
Traceback (most recent call last):
  File "/usr/local/bin/uniconvertor", line 13, in <module>
    uniconv_run()
  File "/Library/Python/2.6/site-packages/uniconvertor/__init__.py", line 83, in uniconv_run
    from app.io import load
  File "/Library/Python/2.6/site-packages/uniconvertor/app/__init__.py", line 69, in <module>
    from conf.configurator import Configurator
  File "/Library/Python/2.6/site-packages/uniconvertor/app/conf/configurator.py", line 11, in <module>
    from app.events import connector
  File "/Library/Python/2.6/site-packages/uniconvertor/app/__init__.py", line 72, in <module>
    from managers.colormanager import ColorManager
  File "/Library/Python/2.6/site-packages/uniconvertor/app/managers/colormanager.py", line 9, in <module>
    from sk1libs.pycms import cmsOpenProfileFromFile,cmsCreateTransform,cmsDoTransform, \
  File "/Library/Python/2.6/site-packages/sk1libs/pycms/__init__.py", line 22, in <module>
    import _pycms, os, types
ImportError: dlopen(/Library/Python/2.6/site-packages/sk1libs/pycms/_pycms.so, 2): Symbol not found: _cmsCloseProfile
  Referenced from: /Library/Python/2.6/site-packages/sk1libs/pycms/_pycms.so
  Expected in: flat namespace
 in /Library/Python/2.6/site-packages/sk1libs/pycms/_pycms.so




my OS version is Mac OS X 10.6.7
python version is 2.6.1

Posted by igor on 03-06-2011 11:08
#2

Hi,

I have answered you in other topic:

http://sk1project...5#post_745

The problem cause is incorrect build fix. Warning/error suppression is not a good way to fix a problem.