Thread subject: sK1 Project :: .ai is unrecognized file type

Posted by ryaz on 20-07-2011 02:55
#1

When I run uniconvertor on an .eps file the generated output file is distorted. The formatting is shifted, the background becomes black, and apostrophes get replaced with question marks.

When I run uniconvertor on an .ai file I get an "unrecognized file type" error:

Code
$ uniconvertor 001.ai ai.pdf
Traceback (most recent call last):
  File "/usr/bin/uniconvertor", line 13, in <module>
    uniconv_run()
  File "/usr/lib/python2.5/site-packages/uniconvertor/__init__.py", line 95, in uniconv_run
    doc = load.load_drawing(input_file)
  File "/usr/lib/python2.5/site-packages/uniconvertor/app/io/load.py", line 377, in load_drawing
    return load_drawing_from_file(file, filename)
  File "/usr/lib/python2.5/site-packages/uniconvertor/app/io/load.py", line 359, in load_drawing_from_file
    raise SketchLoadError(_("unrecognised file type"))
app.events.skexceptions.SketchLoadError: unrecognised file type





The problem is here:
Code
for info in filters.import_plugins:
  match = info.rx_magic.match(line)
  if match:
    loader = info(file, filename, match)
    try:
    ....
  else:
    raise SketchLoadError( ("unrecognised file type"))





So it goes through filters.import_plugins and it looks like it's doing some kind of regex match on the first line of the file, to try to figure out what it is. If it doesn't return from there and exhausts the loop, the else condition is called which raises an exception.

filters comes from sk1libs. There's some plugin with the format_name Adobe Illustrator. Looks like info.rx_magic.match(line) never matches.

I am inputting standard .ai files. (I've tried several.) What should I do?

Edited by ryaz on 20-07-2011 16:56

Posted by zlatan24 on 07-09-2011 14:34
#2

You may use illustrator recovery, which can solve out given trouble. Due to its wide facilities such as working under any Windows OS, using contemporary methods of recovering .ai files after various issues: power failures, viruses.