Thread subject: sK1 Project :: Can't install sk1libs on Mac OSX 10.7

Posted by Gerdchen03 on 05-09-2011 10:31
#1

Hi,

I tried to install sk1libs on my Mac. I downloaded sk1libs-0.9.1 and tried to install using:
sudo python setup.py install

But there is a long list of errors:

src/pycms/_pycms.c:421: error: expected ‘;’ before ‘PyCObject_AsVoidPtr’
lipo: can't open input file: /var/tmp//ccApWHea.out (No such file or directory)
error: command 'llvm-gcc-4.2' failed with exit status 1

Does anybody know where is the fault?

Edited by Gerdchen03 on 05-09-2011 10:32

Posted by TearraMendoza on 05-09-2011 11:24
#2

Hey,

I have the same here. Waiting forward for any suggestions or advices! Thanks in advance.

Posted by Gerdchen03 on 13-09-2011 19:49
#3

Nobody can help?:|

Posted by Wefrebsiddida on 01-03-2012 15:11
#4

?????? ??? ?? ??? ??????????

Posted by Victor on 15-09-2012 09:51
#5

Have you XCode tools installed ?

Posted by Victor on 15-09-2012 09:53
#6

You can try to install LLVM C++ compiler from http://llvm.org/releases/3.1/clang+llvm-3.1-x86_64-apple-darwin11.tar.gz without XCode. But I'm a afraid no any guaranty.