Thread subject: sK1 Project :: Segmentation fault

Posted by Kioshi on 15-07-2009 14:25
#1

I have installed Ubuntu 9.04

i downloaded the .deb package 1.9.1 with no luck.

i downloaded the development package, installed like the instructions said,
and got the same problem

"Segmentation fault"

i tested with an RPM converted with Alien and the same message i got.


Please help... i really need to make it work this :)

thanks

Posted by igor on 15-07-2009 17:08
#2

Please report your system type (32bit, 64bit), processor model and which deb package you have tested.

It's a second bugreport with "Segmentation fault" on application start. I have tested deb package for 32bit system under Ubuntu 9.04 VMWare installation and found that it works correctly.

As alternative I can offer you to try using Mandriva Linux. Due to our collaboration Mandriva provides latest sK1 packages (even fresher than you can download from our site because they use stable SVN snapshots). So you can install Mandriva Linux and use sK1 from Mandriva repository.

Edited by igor on 15-07-2009 17:16

Posted by Kioshi on 15-07-2009 18:32
#3

igor wrote:
Please report your system type (32bit, 64bit), processor model and which deb package you have tested.

It's a second bugreport with "Segmentation fault" on application start. I have tested deb package for 32bit system under Ubuntu 9.04 VMWare installation and found that it works correctly.

As alternative I can offer you to try using Mandriva Linux. Due to our collaboration Mandriva provides latest sK1 packages (even fresher than you can download from our site because they use stable SVN snapshots). So you can install Mandriva Linux and use sK1 from Mandriva repository.


i use 32bit system, Processor model Pentium 4 CPU 3.00GHZ (shows it as dual in SystemMonitor), 1,2GB Ram. i tested .deb 32bit package, dev-svn package, and rpm alienated package. All of them got me with the same message: "Segmentation Fault"

got installed Ubuntu Version 9.04 (Jaunty)
Linux core 2.6.28-13-generic
Gnome 2.26.1

I do not like Mandriva environment, and i dont have too much time to personalize again all the desktop.

If you can share the "Stable SVN snapshot" from Mandriva, ill apreciate it.

If you can show me what happend with the actual SVN, meaby i can help u for other distros.

hope you can reply me soon
thanks

Edited by Kioshi on 15-07-2009 18:36

Posted by igor on 16-07-2009 17:49
#4

You can find latest Mandriva package on following link:

http://rpm.pbone....6.rpm.html

Also another question: did you change Ubuntu preferences or you are using vanile Ubuntu installation? Segmentation fault error usually means a problem in native extensions. So I can suppose that either some package(s) are absent or there is a conflict with desktop environment.

Posted by Kioshi on 17-07-2009 16:53
#5

igor wrote:
Also another question: did you change Ubuntu preferences or you are using vanile Ubuntu installation? Segmentation fault error usually means a problem in native extensions. So I can suppose that either some package(s) are absent or there is a conflict with desktop environment.


i made a vanile Ubuntu instalation to test, downloaded all sugested packages and still got the same message...


ill test now the alienized package of Mandrive... let me see the results

Posted by Kioshi on 17-07-2009 16:56
#6

Code
warning: sk1-0.9.1-0.737.1mdv2010.0.i586.rpm: Header V3 DSA signature: NOKEY, key ID 26752624




ops, can't alienizate it

Posted by Victor on 23-07-2009 18:12
#7

Can you install the Sk1 from sources?
Need to detect what kind of bug it is. Just Unbuntu package is corrupt or sK1 doesn't work on your platform at all.

Posted by Kioshi on 03-08-2009 13:17
#8

i did this:

sudo aptitude update

sudo aptitude install subversion tcl8.5 tcl8.5-dev tk8.5 tk8.5-dev python-cairo-dev python-imaging python-imaging-tk python-reportlab python-liblcms python2.4-dev python2.5-dev python2.6-dev alien liblcms liblcms-dev libcairo libcairo-dev libfreetype6 libfreetype6-dev

svn co https://sk1.svn.sourceforge.net/svnroot/sk1/trunk/sK1 sK1

cd sK1

sudo python setup.py install



still didn't work in Ubuntu 9.04

SEGMENTATION FAULT

Posted by igor on 04-08-2009 05:11
#9

Kioshi wrote:

still didn't work in Ubuntu 9.04

SEGMENTATION FAULT


well... which video card you are using in your computer? Recently we got report about problem with Intel hardware (sk1 works with this driver in Vesa mode only).

I hope next sK1 will fix this issue. Currently we are reimplementing rendering engine and new implementation will be multiplatform so this should eliminate X.org specific extension usage.

Posted by Kioshi on 05-08-2009 21:18
#10

i have 2 computers with graphics acceleration
one with Intel GMA 950 ... and the other one have Nvidia GeForce FX 5200

Posted by joegiampaoli on 13-11-2009 10:54
#11

I get same error installing from source:

Code
[email protected]:~$ sk1
Segmentation fault




Ubuntu 8.04-LTS (32 bit)
1 GB RAM
AMD AThlon 64
Nvidia GeForce 6200

Edited by joegiampaoli on 13-11-2009 10:55

Posted by max on 19-11-2009 18:20
#12

The message "Segmentation fault" consonant with "All, arrived" and did not contain information about the causes of the emergency stop.

1. You installed sK1 the first time?
2. You sk1 has been installed and you update it?
3. Tell us which way to install / upgrade sK1.

Edited by max on 20-11-2009 05:29