Thread subject: sK1 Project :: sK1 fails on startup

Posted by post-factum on 10-05-2009 19:44
#1

I'm using Debian Sid, python 2.5.4-2, tk 8.5.7-1.

Code
[[email protected]]:[~][0]% sk1
shared memory images supported   
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.5/site-packages/sk1/__init__.py", line 19, in <module>
    app.main.main()                                                           
  File "/usr/lib/python2.5/site-packages/sk1/app/main.py", line 150, in main   
    application = SketchApplication(filename, options.display, options.geometry, run_script = options.run_script)                                                                                                         
  File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 156, in __init__                           
    self.build_window()                                                                                     
  File "/usr/lib/python2.5/site-packages/sk1/app/skapp.py", line 194, in build_window                       
    self.main_window = sK1MainWindow(self, self.filename, self.run_script)                                   
  File "/usr/lib/python2.5/site-packages/sk1/app/UI/mainwindow.py", line 113, in __init__                   
    self.build_menu()                                                                                       
  File "/usr/lib/python2.5/site-packages/sk1/app/UI/mainwindow.py", line 919, in build_menu                 
    self.update_mru_files()                                                                                 
  File "/usr/lib/python2.5/site-packages/sk1/app/UI/mainwindow.py", line 937, in update_mru_files           
    self.file_menu.RebuildMenu()                                                                             
  File "/usr/lib/python2.5/site-packages/sk1/app/UI/tkext.py", line 468, in RebuildMenu                     
    self.menu.delete(0, END)                                                                                 
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 2688, in delete                                         
    self.deletecommand(c)
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 364, in deletecommand
    self.tk.deletecommand(name)




The bug is reported to Debian bugtracking system, but for stencil. I get the same with sK1. Could it be corrected?

Posted by rndmerle on 11-05-2009 13:16
#2

Hi.

Same issue for me. I'm using Ubuntu 9.04 x64, with Python 2.6.2 and Tcl/Tk 8.5.6-3
I compiled sK1-0.9.0.tar.gz
When launching /usr/local/bin/sk1 :

Code

shared memory images supported
/usr/local/lib/python2.6/dist-packages/sk1/app/utils/locale_utils.py:9: DeprecationWarning: The popen2 module is deprecated.  Use the subprocess module.
  from popen2 import popen2
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/sk1/__init__.py", line 19, in <module>
    app.main.main()
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/main.py", line 150, in main
    application = SketchApplication(filename, options.display, options.geometry, run_script = options.run_script)
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/skapp.py", line 156, in __init__
    self.build_window()
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/skapp.py", line 194, in build_window
    self.main_window = sK1MainWindow(self, self.filename, self.run_script)
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/UI/mainwindow.py", line 113, in __init__
    self.build_menu()
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/UI/mainwindow.py", line 919, in build_menu
    self.update_mru_files()
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/UI/mainwindow.py", line 937, in update_mru_files
    self.file_menu.RebuildMenu()
  File "/usr/local/lib/python2.6/dist-packages/sk1/app/UI/tkext.py", line 468, in RebuildMenu
    self.menu.delete(0, END)
  File "/usr/lib/python2.6/lib-tk/Tkinter.py", line 2678, in delete
    self.deletecommand(c)
  File "/usr/lib/python2.6/lib-tk/Tkinter.py", line 361, in deletecommand
    self.tk.deletecommand(name)
TclError: can't delete Tcl command





Regards.

Edited by rndmerle on 11-05-2009 13:21

Posted by bob on 12-05-2009 00:00
#3

To confirm - I'm also on jaunty and I get this error when starting skencil.
(I know this forum is for sk1, but I figure this might be relevant. I'm still in the process of installing sk1)

Posted by igor on 12-05-2009 07:27
#4

Hi all,

Thank you for reported issue. We have found the problem reason in latest Python versions so update with fixes will be uploaded soon.

Posted by otx on 12-05-2009 13:41
#5

Same here, Arch linux, python 2.6.2. Any chance to get an updated version in the near future (next couple of days)? That would be awesome!

Regards.

Posted by igor on 12-05-2009 16:06
#6

I think the update will be ready soon. Today we are flying from LGM2009 conference to home and 2-3 day will be required for update preparing and testing.

Posted by otx on 16-05-2009 06:14
#7

Thanks! I'm checking the download section on an everyday basis :) I was on CorelDraw for many years, and now I'm working on linux, so this is my only solution to open those CorelDraw files. I need it desperately. Thanks again for this fine software, I hope in next couple of days I can download a new version which will run on my system :)

Posted by Ulysses on 16-05-2009 16:01
#8

Hi all,

Just did some testing. The following installation procedure seems to work fine in Ubuntu 9.10 alpha (karmic edition) and hopefully also works on Debian systems:

Copy-paste the following commands into a Terminal:

sudo aptitude update

sudo aptitude install subversion tcl8.5 tcl8.5-dev tk8.5 tk8.5-dev python-cairo-dev python-imaging python-imaging-tk python-reportlab python-liblcms python2.4-dev python2.5-dev python2.6-dev alien liblcms liblcms-dev libcairo libcairo-dev libfreetype6 libfreetype6-dev

svn co https://sk1.svn.sourceforge.net/svnroot/sk1/trunk/sK1 sK1

cd sK1

sudo python setup.py install

Run sk1 to launch the program

Regards,

Mark

Edited by Ulysses on 16-05-2009 16:01

Posted by otx on 17-05-2009 07:11
#9

Works on Arch too, thanks !

Posted by wmello on 28-05-2009 21:30
#10

Works ubuntu 9.04
Tanks!
sK1 Works!!!!! :D

Posted by indigene on 01-09-2009 16:00
#11

9.04 64-bit here.
Followed Ulysses' advice. Got SK1 to open. Thanks.

But a multipage cdr file opened all jumbled, looks like only it only took figures, can't see any text. Also tried to convert cdr to svg using uniconvertor - it did create an svg but gave this error:

/usr/lib/python2.6/dist-packages/uniconvertor/app/utils/locale_utils.py:9: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
from popen2 import popen2

On opening the svg in inkscape I find its blank.

Tried with a single page image only cdr file. This one opened just fine in sk1 & the converted svg opened fine in inkscape, though the same error message appeared on conversion.

Help please:|

Edited by indigene on 01-09-2009 16:41

Posted by max on 01-09-2009 18:13
#12

Hi.

There are no bugs. This behavior is normal now.
All these changes are implemented in the next release.

Thank you.

Posted by farrahlewis on 05-11-2009 12:01
#13

This topic should be closed seems like the thread started already solved his/her issue.

Regards,
farrahlewis101
Ordinateur portable pas cher