Thread subject: sK1 Project :: Mac OS X 10.6 unable to open .cdr files

Posted by MF on 06-09-2009 10:33
#1

Hi there!

Firstly, I'm very appreciate to you for all you've done to free people from jail of win+coreldraw!

I've worked several years on win and mac computers same time, but finally after releasing Mac os X 10.5 Leopard, mac became a winner. So, I've had to use VMware virtual Windows just to have possibility to open some my old .CDR projects, and some our customers think, that corel s kinda industry standard, and it's not able to make them look at AI, pdf and eps.

Lately, i've upgraded to 10.6 - Snow Leopard, and my old-never-upgrated VMWare said "i'm sorry dude, go, smoke somewhere, time's up to forget about windows", So I decided to completely get rid of that old win32-crap on my HDD and I found wonderful INKSCAPE. And your UniConverter. I've tried to install everything in several combinations, and finally Inkscape is working, and it sems to me that all Uniconverter's files on appropriate places, but as long as I try to open any .CDR file, I'm getting error message:

"
UniConvertor failed:

Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/Library/Python/2.6/site-packages/uniconvertor/__init__.py", line 64, in <module>
from app.io import load
File "/Library/Python/2.6/site-packages/uniconvertor/app/__init__.py", line 62, in <module>
from conf.configurator import Configurator
File "/Library/Python/2.6/site-packages/uniconvertor/app/conf/configurator.py", line 11, in <module>
from app.events import connector
File "/Library/Python/2.6/site-packages/uniconvertor/app/__init__.py", line 114, in <module>
_import_PIL()
File "/Library/Python/2.6/site-packages/uniconvertor/app/__init__.py", line 103, in _import_PIL
warn.warn(warn.USER, "Can't import the Python Imaging Library")
NameError: global name 'warn' is not defined

"
Maybe I've installed your module wrong way, but I can't find any solution

Inkscape version: "Inkscape 0.47pre0 r21549, built Jun 13 2009" (I learned from their forum that it's only version which will work on OS X 10.6)

Hope to hear from you soon!
;)

Posted by max on 06-09-2009 11:52
#2

Hi,

You need to install Python Imaging Library (PIL)
http://www.python...ducts/pil/

Posted by MF on 06-09-2009 12:19
#3

I've googled a bit, and found that Mac OS x comes with Python pre-installed, so, I've just checked in Terminal, so I have:
"Python 2.6.1 (r261:67515, Jul 7 2009, 23:51:51)
[GCC 4.2.1 (Apple Inc. build 5646)] on darwin"

Any ideas?

Posted by MF on 06-09-2009 12:25
#4

Sorry, I've just didn't understand you correctly,

PIL is exactly that was needed!

Now everything works just PERFECTLY!

THANX a ZILLION!

Posted by void on 29-01-2010 13:45
#5

Hello people,

having problems to install PIL for Snow Leopard. Tried to follow different tutorials but none of theses worked for me :( Finally installed py26-pil using macports and made symbolic link from macports instalation directory to /Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/site-packages/uniconvertor
but continue in getting error messages.
Any ideas how to fix it or a different workaround?

Thanks,
V.

Posted by philippp on 29-07-2010 12:56
#6

Hi,
I have similar problems...
Installed MacPort, downloaded uniconvertor and libs to /usr/local/bin and then I did:

sudo tar -xf uniconvertor-1.1.5.tar
cd uniconvertor-1.1.5
sudo python setup.py install

sudo tar -xf sk1libs-0.9.1.tar
cd sk1libs-0.9.1
sudo python setup.py install

then, as MacPort suggested, I did:
sudo port install python_select
sudo python_select python26


but the sk-Libs wont compile:

building 'sk1libs.pycms._pycms' extension/usr/bin/gcc-4.2 -fno-strict-aliasing -fno-common -dynamic -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -DMAJOR_VERSION=1 -DMINOR_VERSION=0 -I/opt/local/Library/Frameworks/Python.framework/Versions/2.6/include/python2.6 -c src/pycms/_pycms.c -o build/temp.macosx-10.6-x86_64-2.6/src/pycms/_pycms.o -Wallsrc/pycms/_pycms.c:21:18: error: lcms.h: No such file or directory

lcms is already installed!
I tried installing lcms2 via MacPort, but this does not help.
There is nothing like py...dev on MacPorts.

Is there an easy solution?

Where is that donation button for getting an OSX install package!?

Regards,
Philipp

Posted by igor on 31-07-2010 14:43
#7

Hi,

The problem cause is LCMS headers absence:

error: lcms.h: No such file or directory


To compile the package you need installing LCMS library headers.

Posted by keramzyt on 10-08-2010 14:10
#8

Hi,
I have the same problem as philippp
How to install LCMS library headers?
LCMS is already installed.

Regards,
Marek

Posted by FCron on 11-10-2010 07:18
#9

mac 10.6 uniconverter cook reciept:

sudo port install lcms2
sudo port install freetype

tar xzf sk1libs-0.9.1.tar.gz && cd sk1libs-0.9.1
CFLAGS="-I/opt/local/include -I/opt/local/include/freetype2" LDFLAGS="-L/opt/local/lib" python setup.py build
sudo python setup.py install

tar xzf uniconvertor-1.1.5.tar.gz && cd uniconvertor-1.1.5
sudo python setup.py install

Posted by dextras on 05-05-2011 13:55
#10

FCron wrote:
CFLAGS="-I/opt/local/include -I/opt/local/include/freetype2" LDFLAGS="-L/opt/local/lib" python setup.py build

In this command i just had to add another directories where lcms was installed:

Code
CFLAGS="-I/sw/include -I/opt/local/include -I/opt/local/include/freetype2" LDFLAGS="-L/opt/local/lib -L/sw/lib" python setup.py build




Everything else worked perfectly! Thank you for the solution!
cheers!

Edited by dextras on 05-05-2011 14:00

Posted by luizping on 28-03-2012 11:46
#11

Getting same error: lcms.h: No such file or directory

I checked and lcms.h is there (/opt/local/include)

I tried:

CFLAGS="-I/opt/local/include -I/opt/local/include/freetype2" LDFLAGS="-L/opt/local/lib"

but no success.

Any idea on how can i force setup.py use /opt/local/include/lcms.h

Posted by igor on 31-03-2012 21:35
#12

Try adding the header place in setup.py:

Code

    pycms_src = src_path + 'uc2/cms/'
   pycms_module = Extension('uc2.cms._cms',
         define_macros=[('MAJOR_VERSION', '1'),
                  ('MINOR_VERSION', '0')],
         sources=[pycms_src + '_cms.c'],
         include_dirs=['/opt/local/include'],
         libraries=['lcms'],
         extra_compile_args=["-Wall"])